fbpx

Having an issue with videos not playing on my site?

I’ve heard from a small number of members (about 3) telling me they can’t view my videos any more on the site. They all were describing the same issue, so I knew something was going on. I personally couldn’t replicate it though, which is the worst. Well, after further investigation, I figured it out… macOS Catalina 10.15.1. It seems Safari and macOS Catalina 10.15.1 have an issue with my videos. I embedded the videos on a couple other sites to make sure it isn’t the host. I also stripped WordPress down to nothing to make sure it isn’t WordPress. It all came back to one common denominator… Safari and Catalina 10.15.1.

I have a ticket into Vimeo and Apple to let them know something is going on. I hope to have some more news sooner than later. In the meantime, if you are using Catalina, you can always use another browser to watch my videos. Other browsers work fine. I recommend Brave. It’s based off of Chrome but without all the tracking.

Sorry about this! I hope to have a resolution soon!

UPDATE FROM NOV 5: Vimeo has confirmed there is an issue with macOS Catalina 10.15.1. They are looking into it. Hopefully this will be resolved soon.

UPDATE FROM NOV 11: Vimeo has escalated the issue. I’ll keep you posted.

NOV 14 UPDATE: Vimeo is still looking into it, haven’t heard anything from Apple. I did find a way to make it work, just click on the playhead about 10 seconds in, the video will play. So it seems it just can get started. Not a great solution, but it works. I’ll keep you posted.

Wait… Try my Site Out for 2 Days

No payment information is needed. All tutorials and lessons are unlocked for 2 days. Sign up for my newsletter to find out how.
Scroll to Top